Gravity Forms eWAY v2.2.6

Gravity Forms eWAY v2.2.6 has just been released. This release brings Gravity Forms 2.3 compatibility; fixes handling of Japanese Yen (JPY); and fixes Gravity Forms HTML5 Validation plugin compatibility.

Gravity Forms 2.3

Gravity Forms 2.3 is due out soon, and it brings changes to the database structure used to store form entries. This release removes any direct access to Gravity Forms tables, using API calls instead, so that it will maintain compatibility with all versions from 2.0 up.

Japanese Yen

Setting the currency to Japanese yen (JPY) now works correctly. It was treating yen the same as dollars and converting them to “cents” by multiplying by 100, for the eWAY API, leading to charges much bigger than required! Now fixed.

Gravity Forms HTML5 Validation

When the Gravity Forms HTML5 Validation plugin was activated, Client Side Encryption was failing completely. This in turn lead to the classic error, “V6111: Unauthorised API Access, Account Not PCI Certified”. I’ve changed the code for Client Side Encryption to account for plugins like Gravity Forms HTML5 Validation.

You can update to the latest version from your WordPress plugin admin page. Here’s the full changelog for Gravity Forms eWAY.

Posted on