Flexible Map supports Google Maps API key

Flexible Map v1.12.0 has just been released. This release adds support for a Google API key, which is now required for all new websites.

Google now requires all new websites using its maps API to have an API key. This applies to all websites that started using the Google Maps JavaScript API since 22 June 2016. You can read more about the decision and its implications on this Google blog post:

Building for Scale: Updates to Google Maps APIs Standard Plan

To get an API key, visit the Google Maps JavaScript API page and click on the GET A KEY button, then follow the prompts. Once you get your key, paste it into the new Flexible Maps settings page.

adding an API key to Flexible Map

You can update to the latest version from your WordPress plugin admin page. Here’s the full changelog for Flexible Map.

Posted on