eWAY Payment Gateway v4.3.0

eWAY Payment Gateway v4.3.0 has just been released. This release requires minimum PHP 5.4 (recommend 7.1 or greater); adds support for Event Espresso 4; and allows disabling the transaction ID in WooCommerce emails.

Minimum PHP version is 5.4

I’ve bumped the minimum supported version of PHP to version 5.4 (while recommending 7.1 or greater). Eventually I’ll raise the minimum version to 5.6 or 7.1, but raising the minimum to 5.4 allowed me to clean up the code a lot, making it easier to maintain and add new features. If you’re still running PHP 5.3, please update — PHP 5.3 is old, obsolete, and unsupported. (For that matter, so is PHP 5.4!)

Event Espresso 4

The eWAY Payment Gateway plugin now supports Event Espresso 4! Thanks to the wonderful Rural Aid Australia who needed this for themselves and agreed to allow others to benefit. Rural Aid does a fantastic job helping people in rural Australia.

WooCommerce emails

WooCommerce order emails automatically get the transaction ID added, for the reference of both the customer and the merchant. If you don’t want that on your order emails, you can now disable it from the payment settings.

You can update to the latest version from your WordPress plugin admin page. Here’s the full changelog for eWAY Payment Gateway.

Posted on